Please Help Support by Donating

  • 2022-06-29, 18:44:46
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search


Looking for VTMR Modding Tutorials? Check out the Modding Tutorials section of

Pages: 1 2 [3] 4 5 ... 10
 on: 2018-02-12, 13:40:51 
Started by Javokis - Last post by Javokis
I have forgotten to explain some extra features in AoR's readme so I'll post them here and make sure the readme is updated in future releases:

*[Vanilla] Damage Calculations

Restores the vanilla game's damage calculation rules - including some of its bugs. Age of Redemption has done several changes to how damage is calculated based on world of darkness pen and paper rules. Much of these rules have been applied to the vanilla game, but some bugs tend to occur around firearms. Vampires are supposed to take conventional firearm damage as normal damage type, which vampires can soak normal and lethal with their stamina. Firearms become even less effective since vampires take 50% damage from normal damage types. This makes incendiary rounds essential for fighting vampires with firearms. In vanilla, firearms rely on a specific flag setting that changes all damage types from bullets into normal/lethal. So in vanilla, there's a strange and random chance firearms will do lethal damage to vampires regardless of its damage type. Humans are supposed to take lethal damage from conventional firearm rounds regardless of whether it is set to normal damage type. In vanilla, humans are taking normal damage from firearms, which they soak with their stamina. Humans can only soak normal damage with stamina, but are supposed to take lethal damage from firearms. This is why it takes more shots just to kill a human on vanilla damage calculations. This is obviously a bug when you take in account the pen and paper rules.


Age of Redemption's damage calculations also implement bullet-proofing requirements for armor. In modern times, you will see certain armor have a bullet-proofing efficiency percentage. This percentage indicates the amount of soak that armor can absorb from bullets.Without bullet-proofing, your armor will not soak any bullet damage. You can enable the [Vanilla] Damage Calculations to restore normal armor functions to the game.

I have also forgot to put the new console command [stcmd toglog] into the readme. Here's the explanation of this console command:

[stcmd toglog]

Toggles Age of Redemption's script logging system. This system will log AI behavior, damage/soak calculations, and configuration settings applied to npcs. These three aspects are separated into three log files located in the VTMR>AoR\ directory and will log the last 200 events in the system to print to these files.

 on: 2018-02-12, 09:01:39 
Started by Question - Last post by Javokis
This was actually explained in the front page about damage being calculated for pnp - I guess not everyone knows what that means so I'll explain here. The let's play [during modern day chapters] covered the new bullet-proofing mechanic [which I did forget to put in the readme, but it was still showcased on the let's play]. Bullet-proofing is not really part of the pnp rule set and is unique to this addition of aor as a form of realism.

Armor now needs bullet-proofing to actually start soaking bullet damage - bullet-proofing is actually shown on the relevant armor. Otherwise, vampires will soak normal bullets with their stamina + soak enhancing disciplines [Like Fortitude]. Conventional rounds are also halved in damage against vampires, hence why fire type rounds are essential against vampires. Humans cannot soak bullet damage with stamina because they are human. Humans are weak compared to vampires and this is noted in the wod pnp rules. Humans [and all non-vampires] take bullet damage as lethal [like in pnp] and cannot soak with stamina [except for certain monsters like werewolves]. Some npcs have bullet-proofing, but those that don't cannot soak firearms with their armor as was noted in the log you posted above.

Bullet proofing is shown as a %. So that is the efficiency of the soak against bullets. If it says 50% then only 50% of the soak will absorb bullet damage. Tailored Armor has efficiency of 120% which makes it still the best armor in the game. This armor is expensive and is only available in New York chapter.

Oh and to get the toglog command to work in MP, you have to spawn the ST head. You go into ST mode then right-click at the ground. That will spawn the ST Head. Then you can type in stcmd commands from aor.


 on: 2018-02-12, 08:32:22 
Started by Question - Last post by Javokis
You seem to think that the public SDK is actually the developer's licensed tools. They are not the same. The public SDK is for modders and not the original developer's tools. This becomes even more evident when you try to use Embrace to edit Nihilistic's maps and get strange graphical artifacts and sector errors on certain maps you edit. The SDK is NOT the developer's licensed tools. The SDK is a public release of modified tools for modders. Not the same.


See image attachment about how compiler version is set for eclipse:

 on: 2018-02-12, 04:30:25 
Started by Question - Last post by Question
OK im trying out the toglog command now. I went into the setite temple and shot some setites with a rifle which (supposedly) does 110 damage.

41: Christof does 80 normal damage to Setite

This is nowhere close to 110...

42: Setite's armor cannot soak firearms.

So im guessing you made guns ignore all bashing soak values or something?

43: Setite soaks 42 normal damage from Christof

Where is this soak value coming from then? The Setite' sstamina? And you made Humans unable to soak damage from guns with their stamina right?

The toglog command doesnt appear to work in MP so i cant use the ST tools to check the enemy HP unfortunately.

The inconsistency with combat messages is probably because you are calculating damage from scripts or something. Which would explain why changing shotgun slugs to do 300 damage causes the messages to flip out...the game isnt using the projectile damage values to calculate damage anymore, but combat messages is, so its creating massive soak values out of nowhere so that the final damage is correct.

Still doesnt address the problem where buckshot is incapable of hurting non-humans though. Or even slugs being unable to hurt Setites.

It would have been a LOT easier if this info was in the readme...i checked the readme and changelog and i cant find any mention of this. People should not need to do this kind of testing to make guesses at how your mod works.

 on: 2018-02-12, 03:45:00 
Started by Question - Last post by Question
Did you even look at the screenshots...nothing in your readme or changelog mentions anything about ranged weapons doing half damage, etc and its a bit much to expect everyone to view all your videos from start to finish just to know what changes you have made.

You really should consider the possibility that some of these are bugs...and not features. Wraiths teleporting into walls every few seconds and breaking party AI is a feature? I highly doubt that.

Ranged weapons doing dramatically lower damage than intended is a vanilla issue, which I just confirmed. It's why throwing knives/shurikens have the weapon listed as 20 damage and the projectile itself does 50 damage.

Also figured out why NPCs take so long to fire shotguns...they use weap_shotgun which has a reload time of 4.5 seconds, whereas the player version has a reload time of 1.33 seconds.

That's two issues which are not features of your mod already.

 on: 2018-02-12, 03:31:06 
Started by Question - Last post by Question
Im trying to open some animation .nad files, but NodView simply cannot open anything. Yes, I am running with the command line parameters. Here's an example :

D:\Vampire The Masquerade - Redemption2\NodSDK>nodview -anim chrisattackshotgun.nad

NodView is in D:\Vampire The Masquerade - Redemption2\NodSDK. But no matter what I try to open, it complains the command line parameters are bad.

I tried moving the .nad and .nod files directly into the NodSDK folder, but it seems to make no difference.

The readme says to use "C:\Games\Vampire>NodSDK\nodview -model christof.nod" but that doesn't work either, it still complains about bad command line parameters.

What am I missing?

Im on win 7 64bit if it makes a difference.

 on: 2018-02-12, 03:25:34 
Started by Question - Last post by Question
Winrar definately works fine, as I have made changes to resources.nob and i can put the vanilla back into codex.nob with no issues.

What do you mean by "version 1.1"? The program im using (DrJava) only includes an option for "Eclipse 4.5".

All I wanted to do was change some durations in disciplines.class. The game cant handle that without freaking out? How did the devs even make any changes in the first place then?

 on: 2018-02-10, 12:48:49 
Started by Question - Last post by Javokis
VTMR will only read .class files formatted to version 1.1 in the compiler. As for making .nob files, I typically have to use an older version of 7zip [version 4.65] because all newer 7zip versions use an incompatible security encryption that I can't seem to turn off. Though I have heard from mod authors that winrar works fine.

When I made the eclipse workshop and eclipse download available I recently made sure that the correct package compatible with 1.1 library was included [JRE 6], which is the last JRE that includes now deprecated commands that VTMR relies on. Make sure your project is setup to format to version 1.1 class compilation and that the JRE library is setup to run version 6u45.

Also note that it's never advised to modify and include modified discipline.class into your mod as this causes a bug in the game engine to stop calculating sanity check protocols. This can cause disciplines to [double tap] when cast, which causes bad data to fill into memory. Best thing to do is create a dependent script derived from discipline.class with overloads. This will make for the most stable modification to disciplines.

 on: 2018-02-10, 11:58:16 
Started by Question - Last post by Question
I installed the nod SDK which comes with .java files, and I tried modifying to change durations of disciplines.

I compiled it into a .class file, but when i put the file into the codex.nob, no disciplines show up ingame at all. E.G. If i create a caitiff MP character, the discipline page is completely blank.

Im using winrar and selected "store" which is 0% compression, and i can see in codex.nob that discipline.class is 9,664 bytes for both "Size" and "packed size".

Is there something else i need to do to get it to work? If i extract the discipline.class file from a vanilla codex.nob and move it over, it works, but noot if i use this modded discipline.class.

I did notice that in, there is :

   protected   static final int      CONSOLE_FLAG_DISCIPLINECAST         = 0x8;
   protected   static final int      CONSOLE_FLAG_DISCIPLINERECAST      = 0x8;
   protected   static final int      CONSOLE_FLAG_DISCIPLINEFIZZLE      = 0x8;

But after compiling, the .class file shows that all the 0x8 has been changed to 8. Every compiler i have tried, including the eclipse compiler, has done this. I'm not sure if this is normal or whether it is causing the game to fail to read the discipline.class file properly...

 on: 2018-02-09, 11:01:58 
Started by Question - Last post by Javokis
I don't answer all of your questions because much of that is already addressed in my readme, changelog, and let's play. I don't like having to answer the same question over and over when I've already showcased massive amounts of the mod publicly.

You're just going to have to take the time to research. You're assuming the mod is supposed to have one type of behavior when it's already documented through several mediums that it does something else.

Pages: 1 2 [3] 4 5 ... 10

Page created in 0.063 seconds with 16 queries.